Безопасность в Windows XP

WinSov.com Крупнейший сайт компьютерной документации

Сделать стартовой

VBA.ru - V.I.P. Рекламная сеть
Добавить в избранное
На главную

Документация

OC Windows
OC Linux
OC Ms-dos
Bios
Сети
Безопасность
Web-мастеру
Программисту
Железо
Разное
Софт
Форум
Гостевая
Каталог сайтов
Рассылка
Ежедневные обзоры
программ и статей у
вас в почтовом ящике

Когда оверклокинг бессилен или оптимизация системы

Когда оверклокинг бессилен Или Оптимизация системы

[12.01.2003] by Xpert

Oверклокинг, как средство улучшения производительности компьютера, в наше время перестал быть чем-то необычным. Скорее он стал нормой жизни любого продвинутого пользователя ПК. Если я не прав, запустите в меня Вашим камнем. Эй, какой ламер кирпич кинул?!

Однако, разгон не всесилен. Иногда гнать уже просто «некуда» или оверклокинг невозможен по каким-то иным причинам, но система все равно не удовлетворяет владельца своей производительностью. Тогда на помощь может прийти лишь оптимизация - специальная настройка аппаратного и программного обеспечения. Основным ее принципом является поиск "узких мест", снижающих общую производительность ПК, и, по возможности, их устранение с помощью настроек hardware и software. Конечно, даже тот, кто с компьютером на "ты", не заставит "486-й" летать. Хотя, безусловно, что-то улучшить можно и на нем. Ведь недаром говорят – нет предела совершенству...

Итак, окончательно выяснено, что компьютер "тормозит". Начнем избавляться от этого...

Этап первый – настройка BIOS

Как показывает практика, пользователи винят в низкой скорости работы системы все, что угодно, но только не BIOS. Да и заглядывают туда весьма и весьма редко. Ну, разве что при разгоне :). А зря. Поскольку именно BIOS управляет работой аппаратуры на самом нижнем уровне, и ее настройки могут весьма существенно влиять на общую производительность Вашего ПК.

Хотя пользовательский интерфейс CMOS Setup и перечень настраиваемых с ее помощью параметров сильно зависят от фирмы-производителя и версии, подавляющее большинство современных компьютеров позволяют осуществить все то, что изложено ниже. Работа будет описана на примере Award BIOS, как наиболее широко распространенного в современных ПК.

Что обычно делают, заходя в BIOS, который нужно настроить на максимальную производительность? Правильно, если уж настраивать, так с чистого листа, а, значит, загружаем Optimized Defaults. От Fail-Save Defaults эта опция отличается в основном настройками памяти. Если же такой функции у Вас нет, то загружаем Fail-Save Defaults. Память же обычно настраивается следующим образом: выставляются минимально возможные тайминги. Если Вы в BIOS не в первый раз, то знаете, где и что. Для непосвященных поясняю: такие значения, при которых память работает максимально быстро но не «глючит». За более подробными разъяснениями обращайтесь к мануалу материнской платы (он ведь у Вас всегда под рукой, не так ли?). Память настроена. Что дальше?

Первый раздел – Standard CMOS Features. Перво-наперво следует отключить автоопределение всех IDE-устройств, про которые вы точно знаете, что у Вас их нет. Допустим, у меня на компе ведомых дисков ни на первичном, ни на вторичном канале нет. А посему пункты Primary Slave и Secondary Slave выставлены в None. Еще выставляем жесткий диск (диски) как определенные пользователем. (Пере)определяется при загрузке у нас теперь только CD-ROM. Этого, увы, избежать нельзя.

Следующий раздел – Advanced BIOS Features. Здесь "шмон" заключается в следующем:
- устанавливаем порядок загрузки. Обычно первым идет жесткий диск, все остальные отключаются
- отключаем BootUp Floppy Seek. Параметр был нужен в то время, когда флоппики могли быть как 40 так и 80 дорожек (720 кб и 1.44 мб соответственно). Сейчас надобность отпала, но в BIOS’е почему-то остался
- параметр Quick On-Power Self Test выставляем в Enabled. Отключаем тем самым часть в общем-то ненужных проверок системы
- параметр Init Display (First) выставляется в необходимое значение, зависит от типа установленной в системе видеокарты. Обычно AGP
- параметр IDE HDD Block Mode Sectors устанавливаем в HDD Max. Теперь контроллер жесткого диска сможет загружать одновременно максимально возможное количество данных, что при дефрагментированном диске должно ощутимо улучшить быстродействие
- отключаем все лишние, т.е. не используемые нами порты, дабы они не занимали прерывания. Многие спросят: зачем? "На деле" обработка даже одного прерывания требует от процессора множества всяких действий (кто изучал ассемблер, тот понимает, о чем я). В нашем конкретном случае совершенно ненужных. Это обычно LPT порт (не у всех же дома есть принтер), Serial, Game и Midi. Второе, менее очевидное положительное свойство сделанного, хорошо известное компьютерным профессионалам и сборщикам (я немного отношу себя к первым, а также работаю вторым), - это меньшая вероятность конфликтов устройств по прерыванию, часто встречающаяся в Windows 9X/Me(в более новых версиях – 2000 и ХР – прерывания распределяются самой ОС).

Все, что вы сейчас сделали, большого выигрыша, честно говоря, не даст. Во всяком случае, операционная система в два раза быстрее работать не будет. А вот POST (Power-On-System-Test) будет проводиться быстрее в среднем на пять-семь секунд. Ну и смотрите чуть выше про жесткий диск и прерывания.

Так что там было про операционную систему?

Этап второй – настройка ОС

Первое, что необходимо сделать – это проверить, сделано ли все то, что сделать так просто (один-два щелчка мыши), но делается так нечасто. Это очистка Корзины, удаление временных файлов, проверка диска и его дефрагментация. Уже сделано или сделали? В том порядке, в котором указано? Двигаемся дальше...

Человеческая натура такова, что все, что нам не нужно, очень редко выкидывается. Такая же ситуация обычно и с данными на жестком диске. Хорошо, если они отсортированы, и с первого взгляда можно понять, что к чему. Чаше же всего все совершенно наоборот. Обычно на диске у пользователя процентов десять заняты абсолютно ненужными данными. Объяснение обычно простое: «Ну... жалко удалять». Такие данные либо уничтожаются, либо записываются на внешние носители (CD, оптика и др.), либо в заархивированном виде остаются на диске. Желательно для таких данных предусмотреть отдельный логический диск. Или, на худой конец, папку.

Еще небольшое примечание для пользователей Windows XP. Данная ОС периодически создает так называемые точки восстановления системы, позволяющие в случае необходимости вернуть в прежнее состояние системные файлы. Надо заметить, что размеры этих точек не маленькие, особенно, если их много. Поэтому, если Вы перед ответственными действиями в системе и так архивируете необходимые системные файлы, опцию можно отключить. Заходим в "Свойства системы", выбираем пункт "Восстановление системы" и ставим флажок.

Отключение восстановления системы

Второй шаг оптимизации – это оптимизация использования оперативной памяти. Сюда входит редактирование системных файлов: autoexec.bat; config.sys; win.ini; system.ini и ветвей реестра

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run и HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices.
Здесь могут помочь такие встроенные в Windows утилиты как Sysedit и msconfig, программы Starter, StartEd, AutoRunMan, RegRun, TweakUI, WinBoost, WinHacker и другие многочисленные твикеры.

Скриншот встроенной утилиты msconfig

Общие рекомендации таковы: исключаем все, что кажется нам лишним, запоминая сделанные исправления. Интересный список того, что можно и нельзя удалять из автозагрузки есть на этой странице. Весьма интересно и полезно, написано профессионалами, а потому оставлю без комментариев. Результатом данных операций является исключение запуска приложений и драйверов, не нужных нам, но "жрущим" ресурсы.
Небольшое отступление: таким "пожирателем", причем весьма и весьма нещадным, является и Антивирус Касперского. Безусловно, его методы анализа весьма хороши, но тормозит он даже мощные машины. Советую заменить его чем-нибудь менее требовательным, например DrWeb или Norton Antivirus. При гораздо более скромных требованиях, защищают они на мой взгляд ничуть ни хуже.

Третье, что нам необходимо сделать – это удалить из системы всякие красивости, ее тормозящие. В общем-то можно бы было отнести ко второму, но, считая чрезвычайно важным, вывожу отдельным пунктом. Сначала немного добавим - зайдем в дополнительные свойства экрана и на вкладке "Адаптер" или "Диагностика", зависит от ОС, установим ползунок в крайнее правое положение, разрешив тем самым полное аппаратное ускорение, т.е. ускоряем все операции по работе с видеопамятью на уровне адаптера.

Включаем полное аппаратное ускорение

Дальше начнем обрезать. Первое, что я обычно делаю – смотрю количество цветов. 32-х битный цвет конечно круто, но чем хуже 16-ти битный? Отличить сложно. А вот на 256-ти цветах глаз уже замечает обеднение палитры, хотя, если вы не работаете с графикой, этого будет вполне достаточно. Второе - убираю Active Desktop. Причина проста – тормозить он(оно) перестает лишь если у Вас на компьютере оперативной памяти более 64 мб. Третье – устанавливаю стандартную виндовую тему оформления Рабочего стола, как самую экономичную. Затем – убираю обои с рабочего стола. Зачем? Вспомним, как и когда многоуважаемый мастдай перерисовывает экран. Делает он это тогда, когда изменится содержание ЛЮБОГО окна. Или окно перетащат. Причем перерисовывается ВЕСЬ экран. Надеюсь ясно, что наличие у Вас на Рабочем столе фотографии Вашей девушки (Вашего парня, дорогие оверклокерши, приветствую!) хотя и весьма неплохо смотрится, но тормозит комп. (Сколько весит качественная фотка? Правильно, уж точно больше мегабайта.) Дальше – больше. Отключаем визуальные эффекты. В Win 9x/Me местонахождение не помню точно, где-то в свойствах экрана, там же, где значки изменяются. Вспомнил – смотрите вкладку "Эффекты". В Win XP - в Свойствах Системы, вкладка «Дополнительно». Убирать можно ПОЧТИ ВСЕ или по принципу «чем больше, тем лучше». Опять же для пользователей ХР – отключение(снятие) флажка "Использование стилей отображения для окон и кнопок" приводит к ... В общем, все овальные кнопочки, заголовки и др. и т.п. исчезают. См. скриншот и убеждайтесь.

Вот что можно за несколько секунд сделать из Windows XP

Нехорошо также, если десктоп у Вас набит ярлыками, как бочка селедкой. Причины те же, что и с "обоями". Совет: создайте папку, например, C:\WhatINeed, туда – все нужные ярлыки, а ярлык к папке поместите на панель быстрого запуска. Дешево и сердито...

Далее оптимизируем дисковую подсистему. Сначала немного теории. Так как ОС весьма часто обращается к жесткому диску, например для работы с файлом подкачки, а скорость обмена данными с диском намного ниже, чем с оперативной памятью, то производительность дисков весьма и весьма существенно влияет на общую скорость работы системы. Для разных «выней» настройки находятся в разных местах, но выполняют по сути одни и те же функции. Для Win 9x заходим во вкладку "Быстродействие" свойств системы, кликаем "Файловая система". Делаем следующее:
- вкладка "Жесткие диски" - ползунок "Оптимизация упреждающего чтения" передвигаем в крайнее правое положение, заставляя Windows пытаться считывать данные с жесткого диска заранее. Если в списке "Типичная роль этого компьютера" выбрать "Сервер сети" то компьютер буде также работать быстрее, однако возрастут его аппетиты по отношению к оперативной памяти. Данный пункт включает кэширование записи на диск, поэтому могу рекомендовать его лишь в том случае, если у Вас редки проблемы с электричеством, поскольку при внезапном отключении питания данные могут просто не успеть записаться на диск.
- вкладка "Компакт-диски" ползунок "Дополнительная кэш-память" до упора вправо, в списке "Оптимизация доступа" выбираем необходимое значение. Сейчас обычно – "для четырех- и более скоростных устройств".
Для пользователей Windows XP cитуация совершенно противоположная, а именно: кэширование записи на диск лишь уменьшает быстродействие. Дело в том, что система по умолчанию рассчитана на работу с дисками и очень старыми и самыми современными. А поскольку большинство современных хардов поддерживают прямую запись на диск, то кэширование абсолютно не нужно. Заходим в диспетчер устройств, ищем там свой или свои HDD и снимаем флажок.

Отключение кэширования дисков в Windows XP

Операции с диском после всего проделанного должны идти быстрее. Ну и конечно, не забывайте про его регулярное сканирование, очистку и дефрагментацию.

Заключение

Вот, пожалуй, и все. Безусловно, мной были рассмотрены лишь основные приемы повышения производительности системы. Хотя все то, что описано, должно значительно поднять быстродействие вашего железного друга. Хотя и не измерить это ни мегагерцами, ни кадрами в секунду, ни какими-либо другими показателями. Разве что «на глаз». Но мы-то с Вами знаем, что стало лучше, и это радует.

Послесловие

Подчеркну, что статья в основном ориентирована на начинающих пользователей ПК, именно поэтому круг вопросов столь узок и не затрагивает многих потенциально опасных настроек системы. И небольшая отмазка – все, что написано мной в этой статье является плодом только моих личных изысканий и опыта, несмотря на то, что про каждую строку можно сказать "я это уже где-то видел; это так просто, что и писать не стоило". Предвидя такие нападки, скажу: а давно ли Вы сами все это узнали? Ведь каждый же когда-то был "чайником". А чайники бывают разные. Нет, не Tefal и Bosch, а те, кто имеет желание научиться и те, кто не имеет. Первым иногда просто не хватает информации, а вторым по фигу. Вторых я называю ламерами. К первым же отношусь с уважением, поскольку сам был таким.
И если мои советы кому-то помогут, буду только рад.

Источник: http://pcxpert.net.ru

Последние выпуски

выпуск №22
выпуск №23
выпуск №24
выпуск №25
выпуск №26
архив

Реклама
Статистика:
Rambler's Top100 TopCTO Компьютеры цены продажа
Copyright WinSov © 2003. При использовании материалов ссылка на www.WinSov.com обязательна.
Хостинг предоставлен Vip-host. Administrator & Designer Dovnar Evgeny